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1) Introduction
LoadRunner is an industry-leading performance and load testing product by Hewlett-Packard (since it
acquired Mercury Interactive in November 2006) for examining system behavior and performance,
while generating actual load. LoadRunner can emulate hundreds or thousands of concurrent users to
put the application through the rigors of real-life user loads, while collecting information from key
infrastructure components (Web servers, database servers etc). The results can then be analysed in
detail, to explore the reasons for particular behaviour.
Consider the client-side application for an automated teller machine (ATM). Although each client is
connected to a server, in total there may be hundreds of ATMs open to the public. There may be
some peak times
such as 10 a.m. Monday, the start of the work week
during which the load is
much higher than normal. In order to test such situations, it is not practical to have a testbed of
hundreds of ATMs. So, given an ATM simulator and a computer system with LoadRunner, one can
simulate a large number of users accessing the server simultaneously. Once activities have been
defined, they are repeatable. After debugging a problem in the application, managers can check
whether the problem persists by reproducing the same situation, with the same type of user
interaction.

LoadRunner
LoadRunner is divided up into 3 smaller applications:
The Virtual User Generator allows us to determine what actions we would like our Vusers, or virtual
users, to perform within the application. We create scripts that generate a series of actions, such as
logging on, navigating through the application, and exiting the program.
The Controller takes the scripts that we have made and runs them through a schedule that we set up.
We tell the Controller how many Vusers to activate, when to activate them, and how to group the
Vusers and keep track of them.
The Results and Analysis program gives us all the results of the load test in various forms. It allows us
to see summaries of data, as well as the details of the load test for pinpointing problems or
bottlenecks.

Client/Server Load Testing
Modern client/server architectures are complex. While they provide an unprecedented degree of
power and flexibility, these systems are difficult to test. Whereas single-user testing focuses primarily
on functionality and the user interface of a single application, client/server testing focuses on
performance and reliability of an entire client/server system.
For example, a typical client/server testing scenario might depict 200 users that login simultaneously
to a system on Monday morning: What is the response time of the system? Does the system crash?
To be able to answer these questions-- and more--a complete client/server performance testing
solution must
# Test a system that combines a variety of software applications and hardware platforms
# Determine the suitability of a server for any given application
# Test the server before the necessary client software has been developed
# Emulate an environment where multiple clients interact with a single server application
# Test a client/server system under the load of tens, hundreds, or even thousands of potential users
www.softwaretestinggenius.com
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The LoadRunner Solution
# LoadRunner reduces the personnel requirements by replacing human users with virtual users or
Vusers. These Vusers emulate the behavior of real users- - operating real applications.
# Because numerous Vusers can run on a single computer, LoadRunner reduces the hardware
requirements.
# The LoadRunner Controller allows you to easily and effectively control all the Vusers--from a single
point of control.
# LoadRunner automatically records the performance of the client/server system during a test. You
can choose from a wide variety of graphs and reports how you want to view the performance data.
# LoadRunner checks where performance delays occur: network or client delays, CPU performance,
I/O delays, database locking, or other issues at the database server. LoadRunner monitors the
network and server resources to help you improve performance.
# Because LoadRunner tests are fully automated, you can easily repeat them as often as you need.

Using LoadRunner
Using LoadRunner, you divide your client/server performance testing requirements into scenarios. A
scenario defines the events that occur during each testing session. Thus, for example, a scenario
defines and controls the number of users to emulate, the actions that they perform, and the machines
on which they run their emulations.
In the scenario, LoadRunner replaces human users with virtual users or Vusers. When you run a
scenario, Vusers emulate the actions of human users--submitting input to the server. While a
workstation accommodates only a single human user, many Vusers can run concurrently on a single
workstation. In fact, a scenario can contain tens, hundreds, or even thousands of Vusers.
To emulate conditions of heavy user load, you create a large number of Vusers that perform a series
of tasks. For example, you can observe how a server behaves when one hundred Vusers
simultaneously withdraw cash from the bank ATMs. To accomplish this, you create 100 Vusers, and
each Vuser:
# Enters an account number into an ATM
# Enters the amount of cash to withdraw
# Withdraws cash from the account
# Checks the balance of the account
# Repeats the process numerous times

LoadRunner Vuser Technology
The actions that a Vuser performs during the scenario are described in a Vuser script. When you run
a scenario, each Vuser executes a Vuser script. The Vuser scripts include functions that measure and
record the performance of the server during the scenario.
To measure the performance of the server, you define transactions. Transactions measure the time
that it takes for the server to respond to tasks submitted by Vusers. For instance, you can define a
transaction that measures the time it takes for the server to process a request to view the balance of
an account and for the information to be displayed at the ATM.
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You insert rendezvous points into Vuser scripts to emulate heavy user load on the server.
Rendezvous points instruct multiple Vusers to perform tasks at exactly the same time. For example, to
emulate peak load on the bank server, you insert a rendezvous point to instruct 100 Vusers to
simultaneously deposit cash into their accounts.
You use the LoadRunner Controller to manage and maintain your scenarios. Using the Controller, you
control all the Vusers in a scenario from a single workstation.
When you execute a scenario, the LoadRunner Controller distributes each Vuser in the scenario to a
host . The host is the machine that executes the Vuser script, enabling the Vuser to emulate the
actions of a human user

Vuser Types
LoadRunner has various types of Vusers. Each type is designed to handle different aspects of today's
client/server architectures. You can use the Vuser types in any combination in a scenario in order to
create a comprehensive client/server test. The following Vuser types are available:
# GUI (Windows and UNIX)
# RTE (Windows and UNIX)
# Database *(CtLib, DbLib, Informix, Oracle, and ODBC)
# Web*
# TUXEDO*
# APPC*
# Windows Sockets*
# Baan
# Java
# DCOM
# PeopleSoft

Working with LoadRunner
Suppose you want to test a bank server that serves many automatic teller machines (ATMs). The
ATMs provide a full range of banking services to the bank's customers-- such as withdrawing and
depositing cash. To test the bank server using LoadRunner, you create a scenario. The scenario
defines the actions that are performed on the server during the load test. During the scenario that
loads and monitors the bank server, you want to:
# Emulate conditions of controlled load on the server
# Emulate conditions of maximum load on the server
# Measure server performance under load
# Check where performance delays occur: network or client delays, CPU performance, I/O delays,
database locking, or other issues at the server monitor the network and server resources under load

2) The LoadRunner Testing Process
There are five steps in LoadRunner Testing Process:

Step I: Planning the Test
Successful load testing requires that you develop a thorough test plan. A clearly defined test plan will
ensure that the LoadRunner scenarios that you develop will accomplish your load testing objectives.
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Step II: Creating the Vuser scripts
Vusers emulate human users interacting with your client/server system. A Vuser script contains the
actions that each virtual user performs during scenario execution.
In each Vuser script you determine the tasks that will be:
# Performed by each Vuser
# Performed simultaneously by multiple Vusers
# Measured as transactions

Step III: Creating the Scenario
A scenario describes the events that occur during a client/server testing session. A scenario includes
a list of machines that "host" Vusers; a list of Vuser scripts that the Vusers run; and a list of Vusers
that run during the scenario. You create scenarios using the LoadRunner Controller.
Creating the List of Hosts to Run Vusers
For each scenario, you create a list of hosts--machines configured to execute Vuser scripts.
Creating the List of Vuser Scripts
For each scenario, you create a list of scripts that Vusers run during scenario execution.
Creating the Vusers
To each Vuser in a scenario, you assign a Vuser script and a host to run the script.

Step IV: Running the Scenario
You emulate user load on the server by instructing multiple Vusers to perform tasks simultaneously.
You can set the level of load by increasing and decreasing the number of Vusers that perform tasks at
the same time.
Before you run a scenario, you set the scenario configuration. This determines how all the hosts and
Vusers behave when you run the scenario.
For each scenario, you create a list of scripts that Vusers run during scenario execution.
You can run the entire scenario, individual Vusers, or groups of Vusers (Vuser Groups). While a
scenario runs, LoadRunner measures and records the transactions that you defined in each Vuser
script.
The LoadRunner Testing Process

Step V: Analyzing Test Results
During scenario execution, LoadRunner records the performance of the client/server system under
different loads. You use LoadRunner's graphs and reports to analyze the server's performance.

3) Load Test Planning
www.softwaretestinggenius.com
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Developing a comprehensive test plan is a key to successful load testing. A clearly defined test plan
ensures that the LoadRunner scenarios you develop will accomplish your load testing objectives.
As in any type of system testing, a well-defined test plan is the first essential step to successful
testing. Planning your load testing helps you to:
# Load testing means testing your client/server system under typical working conditions, and checking
for system performance, reliability, capacity, etc.
# Client/server testing requires hardware, software, and human resources. Before you begin testing,
you should know which resources are available and decide how to use them effectively.
# Focused testing goals and test criteria ensure successful testing. For example, it's not enough to
define vague objectives like "Check server response time under heavy load." A more focused success
criteria would be "Check that 50 customers can check their account balance simultaneously, and that
the server response time will not exceed one minute."
Analyzing the Client/Server System
The first step to load test planning is analyzing the client/server system. You should become
thoroughly familiar with the hardware and software components, the system configuration, and the
typical usage model. This analysis ensures that the testing environment you create using LoadRunner
will accurately reflect the environment and configuration of the system under test.
Identifying System Components
Draw a schematic diagram to illustrate the structure of the client/server system. If possible, extract a
schematic diagram from existing documentation. If the system under test is part of a larger network
system, you should identify the component of the system to be tested. Make sure the diagram
includes all system components, such as client machines, network, middleware, and servers. The
following diagram illustrates a chain of 60 clothing stores. The clothing stores and clothing distributors
each connect to the same database to update the stock information and to check prices. The
distributors connect to the database server through the branch office LAN, and the clothing stores
connect through a wide area network to the LAN.
Stating Objectives in Measurable Terms
The first step to load test planning is analyzing the client/server system. You should become
thoroughly familiar with the hardware and software components, the system configuration, and the
typical usage model. This analysis ensures that the testing environment you create using LoadRunner
will accurately reflect the environment and configuration of the system under test.
Once you decide on your general load testing objectives, you should provide more focused goals by
stating your objectives in measurable terms. To provide a baseline for evaluation, determine exactly
what constitutes acceptable and unacceptable test results. For example:
General Objective - Product Evaluation: choose hardware for the database server.
Focused Objective - Product Evaluation: run the same group of 300 virtual users on two different
servers, HP and SUN Sparc 6000. When all 300 users simultaneously perform five pre-defined
queries, determine which hardware gives a better response time.

Planning LoadRunner Implementation
Defining the Scope of Performance Measurements
You can use LoadRunner to measure response time at different points in the client/server system.
Determine where to run the Vusers and which Vusers to run according to the test objectives:
Measuring end-to-end response time:

www.softwaretestinggenius.com

Page 6 of 32

An Introduction to LoadRunner – A Powerful Performance Testing Tool by HP
You can measure the response time that a typical user experiences by running a GUI Vuser or RTE
Vuser at the front end. GUI Vusers emulate real users by submitting input to and receiving output from
the client application; RTE Vusers emulate real users submitting input to and receiving output from a
character- based application.
You can run GUI or RTE Vusers at the front end to measure the response time across the entire
network, including a terminal emulator or GUI front end, network and server.

Examining Load Testing Objectives
Your test plan should be based on a clearly defined testing objective. This section presents an
overview of common testing objectives:
# Measuring end-user response time
# Defining optimal hardware configuration
# Checking reliability
# Checking hardware or software upgrades
# Evaluating new products
# Identifying bottlenecks
# Measuring system capacity

4) The LoadRunner Controller at a Glance
The following pages describe the Controller window and explains how to perform
basic scenario operations.
# Opening the Controller
# Selecting LoadRunner Commands
# Managing Scenario Files
# Filtering and Sorting Information
# Using Controller Layouts
Opening the Controller
Set up the LoadRunner environment according to the instructions in the Installing
LoadRunner guide.
To open the Controller:
Select Start > Programs > LoadRunner > Controller.
The Controller window opens with the LoadRunner Controller dialog box inside.
The LoadRunner Controller dialog box includes the following options:
Wizard: Creates a scenario with the aid of the LoadRunner Scenario wizard, an interactive, step-bystep guide to creating a scenario.
New: Creates a new scenario.
www.softwaretestinggenius.com
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Open an existing scenario: Opens an existing scenario
Show at Startup: If you do not want this window to appear the next time you start LoadRunner, clear
the "Show at Startup" check box. Once you clear this checkbox, when you open the Controller, the
window layout from the last time you worked with the Controller appears.

Introducing the LoadRunner Controller
The LoadRunner Controller window contains the following elements:
# Title bar: Displays the name of the scenario on which you are currently working.
# Menu bar Displays the menus from which you select commands.
# Tool bar Provides shortcuts for selecting commands. Clicking on a button executes a command.
# Status bar Provides information on the current state of the scenario.
# Vuser window Displays a list of all the virtual users that can take part in the scenario. You also
create Vusers using this window.

Selecting LoadRunner Commands
You select LoadRunner commands from the menu bar or on the toolbar.
# Choosing Commands from a Menu: You select LoadRunner commands from the menus on the
menu bar. Some commands use standard Microsoft Windows shortcut conventions.
# Choosing Commands from the Toolbar You can execute many LoadRunner commands by
clicking a button on the toolbar in the LoadRunner Controller.

Managing Scenario Files
A scenario describes the events that occur during each load testing session. A scenario contains lists
of hosts, Vusers, Vuser scripts, transactions, and rendezvous points. You create a scenario using the
LoadRunner Controller.
After you create the scenario, LoadRunner saves the information in a scenario file (.lrs). You use the
commands in the File menu to create, open, save, and close scenario files. Some of these commands
are available from the toolbar.
Creating a New Scenario
The New command creates a completely new scenario. Note that the New command clears all the
information displayed in the Controller windows. To create a new scenario, choose File > New, or
click the New button.
You can also create a new scenario by using the Scenario wizard. The wizard is an interactive, stepby-step guide to creating a scenario. To create a new scenario by using the Scenario wizard, select
File > Scenario Wizard.
Opening an Existing Scenario
The Open command opens any existing scenario.
1. Choose File > Open, or click the Open button. The File Open dialog box opens.
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2. Click a file in the File Name list or type a file name in the File Name box.
3. Click OK. The File Open dialog box closes and the scenario appears in the LoadRunner Controller.

Filtering and Sorting Information
Each window in the LoadRunner Controller displays information about the scenario. You can filter and
sort the information that appears in each window.
Filtering information displays only those items that meet the selected criteria. For example, you can
filter the Vuser window to display only those Vusers that are in the READY state.
Sorting information displays all the items in a list in a certain order. For example, you can sort all
Vusers in the Vuser list, in order of their Vuser ID number (1,2,3 etc.).

Using Controller Layouts
By creating Controller layouts, you can define how the Controller window looks before, during, and
after executing a scenario.

5) Creating a Scenario
To develop a scenario, you create a host list, a script list and a Vuser list. This chapter describes how
to create a host list--the list of machines, or hosts, that execute Vuser scripts during a scenario run.

About Creating a Host List
Hosts are the machines on which Vusers run their scripts. The host list displays the machines that can
run Vusers during scenario execution. You can add both UNIX and Windows machines to the host list.
The Host window displays the host list and the following information for each host:
# The status of the host
# The platform type of the host (UNIX or Windows)
# Details of the scenario that is currently running
The Host window has its own menu in the Controller menu bar, and a tool bar that lets you create and
manage the host list.

Creating a Host List
The following procedure outlines how to create a host list for a scenario:
# Install a LoadRunner remote command launcher on every machineB (except for local host)
you want to use as a host.
The remote command launcher is an application that enables the Controller to invoke applications on
the host. For more information about installing LoadRunner remote command launchers.
# Add the names of the hosts to the host list.
# Set attributes for each host (optional).
www.softwaretestinggenius.com
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Host attributes specify the number and type of Vusers that can run on each host. For example, you
can set the maximum number of DB Vusers a host can run.
# Select which hosts will take part in the scenario (optional).
Each time you run a scenario, some hosts may be unavailable. You can temporarily remove (disable)
hosts from the list.

Adding a Host to the Host List
You use the Host window in the LoadRunner Controller to add hosts to the host list. After you create a
host, you can set and modify the attributes for the new host.
To add a host to the host list:
# Start the LoadRunner Controller and open the Host window. The Host menu appears in the
LoadRunner menu bar.
# Choose Host > Add. The Host Information dialog box opens.
# Type the name of the host in the Name box.
# Click a platform in the Platform list (UNIX or Windows).
# By default, LoadRunner stores temporary files on the host during scenario execution in a temporary
directory specified by the host's TEMP or TMP environment variables. To override this default for a
specific host, type a location in the Temporary Directory box.
# If the host is UNIX-based, set the login information for the host. By default, LoadRunner uses your
NT user name for the UNIX login. In other words, if your NT login is lrunner , the Controller will log on
to the host as lrunner . You can also specify to login to the UNIX machine as another user.
# Click OK to close the Host Information dialog box. The host name you entered appears in the Host
window; the host status is set to DOWN

Modifying Host Attributes
Host attributes determine
# The maximum number of Vusers that a host runs
# The initialization quota for a host
# Click a platform in the Platform list (UNIX or Windows).
# The location of the WinRunner configuration file (for GUI Vusers)
# The location of the files during run-time
Setting the Maximum Number of Vusers that a Host Can Run
You can increase or decrease the maximum number of GUI, DB and RTE Vusers that a host can run.
You modify the maximum number according to the available resources, the needs of your scenario,
and your LoadRunner license agreement.
To set the maximum number of Vusers that a host can run:
# Open the Host window. The Host menu appears in the LoadRunner menu bar.
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# Click a host in the Host window. The host is highlighted.
# Choose Host > Details. The Host Information dialog box opens.
# Click the Vuser Types tab.
# In the Maximum Active boxes enter the maximum number of Vusers of each type that the host can
run.
The maximum number of active Vusers that you specify must not exceed the number of Vusers that
you are licensed to run. To check your Vuser licensing limitations, choose Help > About LoadRunner.
# Click OK to close the Host Information dialog box.
Setting the Initialization Quota
The initialization quota determines how many Vusers a host initializes at a time. Initializing a large
number of Vusers simultaneously places large stress on a host. To reduce stress on a host, you can
initialize smaller batches of Vusers.
# Open the Host window. The Host menu appears in the LoadRunner menu bar.
# Click a host in the Host window. The host is highlighted.
# Choose Host > Details. The Host Information dialog box opens.
# Click the Vuser Types tab.
# In the Initialization Quota boxes, enter the maximum number of Vusers of each type that the host
will initialize simultaneously.
# Click OK to close the dialog box.
Setting the Location of the WinRunner Configuration File
A GUI Vuser, running on a Windows-based host, uses WinRunner to execute its Vuser script. To
enable the LoadRunner Controller to open WinRunner, you specify the location of the appropriate
WinRunner configuration file ( wrun.ini ).
To select the location of WinRunner for a GUI Vuser:
# Open the Host window. The Host menu appears in the LoadRunner menu bar.
# Click a host in the Host window. The host entry is highlighted.
# Choose Host > Details. The Host Information dialog box opens.
# Click the WinRunner tab, and then click one of the following options:
Scenario Default: Instructs the Vuser to use the WinRunner configuration file specified in the
Scenario Configuration dialog box.
Local Configuration File: Instructs the Vuser to use the host's WinRunner configuration file.
Path: Instructs the Vuser to use the WinRunner configuration file that is in a specific location on the
network. To specify the path of the configuration file, click the browse button to the right of the Path
box, and then set the location using the Choose WinRunner Configuration File dialog box.
# Click OK. The Host Information dialog box closes.
Specifying where a Host Saves Files During Run-Time
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When a host runs a Vuser script, the Vuser generates results that describe the execution of the script.
By default, these results are saved temporarily on a local drive of each host--until they are collated by
the Controller to a central location. Alternatively, you can select to save the results directly to a shared
network drive.
To change how individual hosts save their results:
# Open the Host window. The Host menu appears in the LoadRunner menu bar.
# Click a host in the Host window. The host entry is highlighted.
# Double-click the host or choose Host > Details. The Host Information dialog box appears. Ensure
that the Runtime File Storage tab is visible.
# To store the scenario results on a shared network drive, click "On a shared network drive," and then
select the Results check box. This option overrides the setting for the scenario.
# To store the results temporarily on a hard drive of the host computer, click "On local host." The
temporary result files will be stored under the temporary directory specified by the host's environment
variables (on Windows, TEMP or TMP and on UNIX, $TMPDIR or $TMP). This option overrides the
setting for the scenario. These temporary results are deleted either when the agent goes down or
when you run the scenario again.
# To store the scenario results according to the scenario default, click "Scenario default". This is the
default setting.
Selecting the Hosts for a Scenario
Before you run a scenario, you can select which hosts will run Vusers. This compensates for the
possibility that some hosts will be unavailable. For example, a machine may already be in use when
you want to run the scenario.
You select which hosts will take part in the scenario by using the Enable and Disable commands.
Disabling a host temporarily removes it from the list. Enabling a host reinstates it.
Disabling Hosts
When you disable a host, the host will not execute Vuser scripts during a scenario execution.
To disable a host:
# Open the Host window. The Host menu appears in the LoadRunner menu bar.
# Click a host in the Host window. The host is highlighted.
# Click the Disable button or choose Host > Disable. The host name changes from black to gray. The
host is disabled.
Enabling Hosts
Enabling a host reinstates a previously disabled host.
To enable a host:
# Click a disabled host in the Host window. The host is highlighted.
# Click the Enable button or choose Host > Enable. The host name changes from gray to black, and
the host is enabled.
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Creating a Multi-Platform Host List
You can add both UNIX and Windows machines to the host list. When you create a multi-platform
scenario, information located on one machine may be inaccessible to other machines. LoadRunner's
Path-Translation table enables many different machines and platforms to share information

Saving and Loading the Default Host List
Using LoadRunner, you can save a host list as the standard (default) list of hosts for creating
scenarios. When you create a scenario, you then adapt the default list to the needs of the new
scenario.
You can save the host list currently displayed in the Host window as the default host list. You can use
this list each time you want to create a new scenario.
To save the host list as the default:
# Choose Host > Save List As Default.
To load the default host list:
# Choose Host > Load Default List. The default host list appears in the Host window, together with
any host previously displayed.

About Creating a Script List
A Vuser script defines the actions that a Vuser performs during scenario execution. The script list
contains all the Vuser scripts that Vusers can run. The script list may contain scripts for GUI, DB, and
RTE type Vusers.
The Script window, which displays the script list, has its own menu in the Controller menu bar. The
Script window includes the following information for each script in the list:
# The name of the Vuser script
# The type of Vuser that will run the script
# The location (path) of the script
# Command line options associated with the script

Adding a Script to the Script List
When you add a script to the script list, ensure that the Controller can recognize the script's path.
During run time, the Controller sends a copy of the scripts to the Vuser hosts.
To add a script to the script list:
# Start the LoadRunner Controller and open the Script window. The Script menu appears in the
LoadRunner menu bar.
# Choose Script > Add. The Vuser Script Information dialog box opens
# Click the browse button to the right of the Path box. The Open dialog box appears.
# In the "Files of Type" box select the Vuser type, and then select the path and file name of the new
script.
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# Click Open to select the files. The Open dialog box closes, and the new script name and its Vuser
type appear in the Vuser Script Information dialog box.
# In the Command Line box, type any command line options to use when running the script. For
example: -x value -y value
# Click OK to close the Vuser Script Information dialog box.

Modifying Script Details
You can modify the details of a script in the script list using the Vuser Script Information dialog box.
To modify the details of a script in the script list:
# Start the LoadRunner Controller and open the Script window. The Script menu appears in the
LoadRunner menu bar.
# Click a script in the Script window. The script is highlighted.
# Choose Script > Details. The Vuser Script Information dialog box opens, displaying the details of the
selected script.
# Modify the details as necessary. Note that you cannot modify the transactions, rendezvous, or
Vusers associated with a script.
# Click OK to close the Vuser Script Information dialog box and save the changes. The modified script
details appear in the Script window.
# In the Command Line box, type any command line options to use when running the script. For
example: -x value -y value
# Click OK to close the Vuser Script Information dialog box.

Using Relative Paths for Vuser Scripts
When you specify the location of a Vuser script, you can specify a relative location. The location can
be relative to the current scenario directory, or the LoadRunner installation directory.
You can specify a path relative to the current scenario directory by typing either of the following
notations at the start of the script path:
.\
indicates that the path is relative to the location of the scenario directory.
..\
indicates that the path is relative to the location of the parent directory of the scenario directory. For
example, if the current scenario is located at F:\scenarios, to specify a script located at
F:\scenarios\scripts\user.usr, you could type:

About Creating the Vuser List
With LoadRunner, you test your client/server system by creating and running scenarios. A scenario
describes the events that occur during a client/server load testing session. Each scenario contains a
list of many virtual users (Vusers). Vusers emulate human users interacting with your client/server
system. When you run a scenario, the Vusers generate load on the server, and LoadRunner monitors
the server's performance.
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For example, to test a bank server you could create Vusers that deposit and withdraw cash using
automatic teller machines (ATMs). LoadRunner would monitor the bank server's performance while
varying numbers of customers simultaneously perform deposit and withdrawal operations

Scheduling Vusers
After you create a Vuser, you can schedule the Vuser by setting:
To schedule a Vuser:
1. Open the Vuser window, and click in the Vuser side of the window. The Vuser menu appears in the
LoadRunner menu bar.
2. Choose Vuser > Details. The Vuser Information dialog box appears.
3. Click the Scheduling tab.
4. Set one of the scheduling options.
5. Click OK to close the dialog box.

Creating Vuser Groups
You can use Vuser Groups to organize the Vusers in a scenario into manageable groups. You create
Vuser Groups that contain Vusers with shared or similar characteristics. For example, you can create
a Vuser Group for all Vusers that run the same Vuser script.
To create a Vuser Group:
1. Open the Vuser window. The Vuser menu appears in the LoadRunner menu bar.
2. Click anywhere in the Vuser Group column. The Vuser Group menu appears in the LoadRunner
menu bar.
3. Choose Group > Add. The Vuser Group Information dialog box opens.
4. In the Name box, enter the name of the Vuser Group and then click OK. The new Vuser Group
appears at the bottom of the Vuser Group list in the Vuser window.
5. In the Command Line box, type any command line options to use when running the group. For
example: -x value -y value

Scheduling Vuser Groups
After you create a Vuser Group, you can schedule the group by setting:
To schedule a Vuser Group:
1. Open the Vuser window, and click in the Vuser Group (left) side of the window. The Group menu
appears in the LoadRunner menu bar.
2. Choose Group > Details. The Group Information dialog box opens.
3. Set one or both of the scheduling options
4. Click OK to close the dialog box.
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Scheduling Vuser Groups
A GUI Vuser can execute a Vuser script either on a Windows-based machine or on a UNIX
workstation. By setting the GUI Vuser type you inform the Controller how to execute the script. For
example, if you set the Vuser type to GUI:XRunner, LoadRunner executes the Vuser script on a UNIX
workstation--using XRunner. You can set the default GUI Vuser type for new GUI Vusers.
To set the default GUI Vuser type:
1. Invoke the Controller and create a new scenario or open an existing one.
2. Choose Options > Settings. The Settings dialog box appears.
3. Click the Default Types tab.
4. Click the arrow to the right of the Default GUI Vuser box. The list of available GUI Vuser types
opens.
5. Click an option in the Default GUI Vuser list. See below for a list and explanation of the available
options.
6. Click OK to close the dialog box and save the information.

Controlling Server Load: Rendezvous Points
During a scenario run, you can instruct multiple Vusers to perform tasks simultaneously by using
rendezvous points. A rendezvous point creates intense user load on the server and enables
LoadRunner to measure server performance under load.
For example, suppose you want to measure how a bank server performs when ten Vusers
simultaneously withdraw cash from ten different automatic teller machines (ATMs). In order to
emulate the required user load on the server, you instruct all the Vusers to withdraw cash at exactly
the same time.
You ensure that multiple Vusers act simultaneously by creating a rendezvous point.
When a Vuser arrives at a rendezvous point, it is held there by the Controller. The Controller releases
the Vusers from the rendezvous either when the required number of Vusers arrive, or when a
specified amount of time has passed.
You define a rendezvous by inserting a rendezvous point into a Vuser script. At the start of the Vuser
script, you declare the names of all the rendezvous points in the script. This declaration enables the
Controller to display rendezvous information when you execute the scenario.

Disabling and Enabling Rendezvous Points
By disabling and enabling rendezvous points, you can influence the level of server load. Disabling a
rendezvous temporarily removes it from the rendezvous list and excludes it from the scenario.
Enabling a rendezvous returns it to the Rendezvous list and includes it in the scenario.
You use the Disable and Enable commands to change the status of rendezvous points during a
scenario.

To disable a rendezvous:
1. Open the Rendezvous window. The Rendezvous menu appears in the LoadRunner menu bar.
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2. Click a rendezvous. The selected rendezvous is highlighted.
3. Choose Rendezvous > Disable, or click the Disable button. The rendezvous name changes from
black to gray and the rendezvous is disabled.

To enable a rendezvous:
1. Open the Rendezvous window. The Rendezvous menu appears in the LoadRunner menu bar.
2. Click a disabled rendezvous. The selected rendezvous is highlighted.
3. Choose Rendezvous > Enable, or click the Enable button. The rendezvous name changes from
gray to black and the rendezvous is enabled.

Disabling and Enabling Vusers at Rendezvous Points
You can influence the level of server load by disabling and enabling Vusers at a rendezvous. By
disabling Vusers at a rendezvous, you temporarily exclude them from participating in the rendezvous.
Enabling disabled Vusers returns them to the rendezvous. You use the Disable and Enable
commands to specify which Vusers will take part in a rendezvous.

To disable a Vuser in a rendezvous:
1. Open the Rendezvous window. The Rendezvous menu appears in the LoadRunner menu bar
2. Click a rendezvous in the Rendezvous window. A list of all the Vusers in the rendezvous is
displayed on the right side of the Rendezvous window.
3. Click a Vuser in the list.
4. Choose Rendezvous > Disable, or click the Disable button. The Vuser changes from black to gray.
The Vuser will not take part in the rendezvous.

To enable a Vuser in a rendezvous:
1. Open the Rendezvous window. The Rendezvous menu appears in the LoadRunner menu bar.
2. Click a rendezvous. A list of all the Vusers in the rendezvous is displayed on the right side of the
Rendezvous window.
3. Click a disabled Vuser in the list.
4. Choose Rendezvous > Enable, or click the Enable button. The Vuser chang

Setting Rendezvous Attributes
Setting the Timeout Attribute
The timeout determines the maximum time (in seconds) that LoadRunner waits for each Vuser to
arrive at a rendezvous. After each Vuser arrives at the rendezvous, LoadRunner waits up to timeout
seconds for the next Vuser to arrive. If the next Vuser does not arrive within the timeout period, then
the Controller releases all the Vusers from the Rendezvous. Each time a new Vuser arrives, the timer
is reset to zero . The default timeout is thirty seconds. You set a timeout for each rendezvous point.
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To set a timeout:
1. Open the Rendezvous window. The Rendezvous menu appears in the LoadRunner menu bar.
2. Click a rendezvous in the Rendezvous window.
3. Choose Rendezvous > Details. The Rendezvous Information dialog box opens.
4. In the Timeout box, enter a timeout value, and then click OK. The timeout is set for the rendezvous.

To set the policy attribute:
1. Open the Rendezvous window. The Rendezvous menu appears in the LoadRunner menu bar.
2. Click a rendezvous in the Rendezvous window.
3. Double-click the Policy field. The field turns into a list.
4. To set the policy to All Arrived, select All Arrived from the list. The new policy appears in the Policy
field.
Alternatively, to set the policy to Quota, select Quota from the list.
The Rendezvous - Quota dialog box appears.
Enter the number of Vusers in the Quota box.
5. Click OK to close the dialog box. The new policy appears in the Policy field.

About Configuring a Scenario
You can configure how hosts and Vusers behave when you run a scenario so that the scenario
accurately emulates a real-world situation. Most of the configuration settings are set using the
Scenario Configuration dialog box.

Setting the Location where Run-Time Files are Stored
When you run a scenario, by default the run-time files are stored locally on each Vuser host. (The
Vuser host is the computer that is running the Vuser script.) By default, the location of the files is
under the temporary directory specified by the host's environment variables (on Windows, TEMP or
TMP and on UNIX, $TMPDIR or $TMP). If the no environment variable is defined, the files are saved
to the /tmp directory.

Besides other file types, run-time files include Vuser script files and result
files:
1. Script files: When you run a Vuser, the Controller sends a copy of the associated Vuser script to
the Vuser host. The script is stored in the host's temporary run-time directory.
2. Result files: While you run a scenario, the participating Vusers write their results to the temporary
run-time file directory. After scenario execution, these result files are collated or consolidated--results
from all of the hosts are transferred to the results directory.
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Specifying the Location of WinRunner
A GUI Vuser running on a Windows host uses WinRunner to execute its Vuser script. To enable the
LoadRunner Controller to open WinRunner, you must specify the location of the appropriate
WinRunner configuration file ( wrun.ini ). The configuration file in the location you specify is the default
configuration file for the entire scenario--all the Windows GUI Vusers in the scenario will access this
file.

To set the default location of WinRunner for GUI Vusers:
1. on each host
2. in a public directory on the network

The default location you specify can be located:
1. Choose Scenario > Configure. The Scenario Configuration dialog box opens.
Click the Environment tab.
2. Click one of the WinRunner Configuration File options
3. Click OK to close the dialog box.

Setting the Scenario Duration
You can set the length of time that a scenario runs.
To set the scenario duration:
1. Choose Scenario > Configure. The Scenario Configuration dialog box appears.
2. In the Session tab, select the Limit Scenario Duration check box.
3. Enter the length of time, in minutes, you want the scenario to run.
4. Click OK to close the dialog box.

Specifying the Applications that the Scenario Invokes
You can create a list of applications that the Controller invokes when you begin a scenario run. You
specify each application and the host on which the application will run.
To specify the applications that the scenario invokes:
1. Choose Scenario > Configure. The Scenario Configuration dialog box opens. Ensure that the
Session tab is visible.
2. For each application to be invoked, type the following statement in the Applications to start at the
beginning of the Scenario box
3. Click OK to close the dialog box.

6) LoadRunner Analysis
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During scenario execution, Vusers generate result data as they perform their transactions. After
running a scenario, you can view the results to determine how your system performed. You can view
scenario results in several ways:
The Analysis graphs and reports provide information about transactions and Vusers that can be
used to determine system performance.
The Export data utility enables you to export scenario results to external applications such as
spreadsheets. You can export scenario data as text files or in one of the common spreadsheet
formats.
The Controller Output window displays information about the scenario run. If your scenario run fails,
look for debug information in this window.
The Vuser output file, output.txt, contain a full trace of the scenario run for DB Vusers. This file is
located in the scenario results directory. (When you run a DB Vuser script in standalone mode, this
file is placed in the Vuser script directory.)

Result Directory File Structure
When you set the results directory, you also specify a results name. LoadRunner creates a
subdirectory using the results name, and places all of the data it gathers in that directory. Every set of
results contains general information about the scenario in a result file (.lrr) and an event (.eve) file
During scenario execution, LoadRunner also gathers data from each Vuser and stores it in a header
file _t_rep.hdr, and an event file _t_rep.eve . LoadRunner creates a directory for each Group in the
scenario and a subdirectory for each Vuser.

Analysis Graphs and Reports
Vusers generate data as they perform transactions during a scenario. You can use this data to
generate graphs and reports that show the performance of your client/server system. Before
generating reports and graphs, you should determine the type of information that you would like to
see. LoadRunner's graphs and reports are divided into the following three categories:
# Activity
# Performance
# Web Vuser
Activity graphs and reports provide information about the number of Vusers and the number of
transactions executed during the scenario run.
Performance graphs and reports analyze Vuser performance and transaction times.
Web Vuser graphs provide information about the throughput and connection times of Web Vusers.
LoadRunner cross-scenario analysis lets you compare the graphs from several scenarios. This
feature is useful for benchmarking hardware in determining how a superior system will improve
performance.

Viewing a Part of the Scenario
You can instruct LoadRunner to calculate graphs and reports based on a part of the scenario. For
example, if you have a scenario with a duration of 400 seconds, but you are only interested in the
period beginning at 60 and ending with 360 seconds, you specify that interval in the Time Filter dialog
box. After setting the time filter, you must rebuild the result database in order for the changes to take
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effect. All subsequently generated graphs and reports are calculated using data only from the
specified interval.
To filter the scenario time:
1. Choose Options > Time Filter in the Analysis window. The Time Filter dialog box opens.
2. Enter the desired time interval
3. Click OK to accept the settings.
4. Choose File > Open (Rebuild)

Working with Analysis Graphs
You generate graphs in the Analysis window by selecting the desired graphs from the Graph menu.
LoadRunner also provides tools which enable you to modify the way that graphs are displayed. For
each graph you can:
# Filter specific transactions and Vusers
# Enlarge a section of the graph
# Change the interval of the x-axis.
Viewing Specific Transactions and Vusers
When you generate a graph, the graph initially includes all the transactions in the scenario. You can
filter the graph to display one or more specific transactions. For example, if three transactions were
monitored during a scenario, you can generate a graph that displays only one of the transactions. By
default, the Transaction Performance and Transaction per Second graphs display all the transactions,
while the Transaction Performance Summary and Transaction Distribution graphs display only the first
transaction.
To select transactions and Vusers to display:
1. Select Results > Analyze Results, or click the Analysis button. The LoadRunner Analysis window
opens, and the Running Vusers graph is displayed.
2. Select a graph from the Graphs menu. The graph is displayed. You can display multiple copies of
the same graph.
3. Select View > Filter, or click the Graphic Filters button.
4. Select the transactions that you want to include in the graph. Use the CTRL key to select multiple
transactions. For graphs that show individual Vuser performance, such as Transaction Performance
Summary by Vuser graph, you can filter the graphs to display information for a single Vuser. Click the
Group and Vuser tab and select the Vuser that you want to display.
5. Click OK. The Filter dialog box closes. The graph appears and displays the selected transactions or
Vusers.
To enlarge a section of a graph using the mouse:
1. Select a graph from the Graphs menu. The graph is displayed.
2. Move the mouse pointer to the beginning of the section that you want to enlarge.
3. Hold down the left mouse button. A vertical bar appears on the x-axis . This marks the first
boundary of the section to enlarge.

www.softwaretestinggenius.com

Page 21 of 32

An Introduction to LoadRunner – A Powerful Performance Testing Tool by HP
4. While holding down the left mouse button, move the mouse to the left or right of the vertical bar. A
second vertical bar appears. This marks the second boundary of the section to enlarge.
5. Release the left mouse button. The section is enlarged.
6. Click the right mouse button to return the graph to its original size.
To enlarge a section of a graph using the Zoom In command:
1. Select a graph from the Graphs menu.
2. Select View > Zoom In, or click the Zoom button. The Zoom In dialog box opens.
3. In the From box, enter the point that marks the left boundary of the section to enlarge. Note that this
point must be on the x-axis.
4. In the To box, enter the point that marks the right boundary of the section to enlarge.
5. Click OK. The section is enlarged.
6. Select View > Zoom Out to return the graph to its previous size.
7. Select View > Full View to return the graph to its original size
To change the granularity of the x-axis for a graph:
1. Select a graph from the Graphs menu
2. Select View > Granularity, or click the Granularity button. The Set Granularity dialog box opens.
3. Enter a new scale in the Granularity box

Working with Analysis Reports
In order to view a report, you must generate the report from the LoadRunner Analysis window.
LoadRunner reports are displayed in a Report Viewer. You can print, save, or export the data using
the viewer.
Selecting and Displaying Reports
When you run a scenario, LoadRunner stores the scenario results in the specified directory. When
you run the analysis, LoadRunner processes the data and formats them into a database. The
formatted data is used to generate reports and graphs. You can instruct LoadRunner to run the
analysis automatically at the end of a scenario by selecting Results > Auto Load Analysis.
To display reports:
1. Select Results > Analyze Results, or click the Analysis button. The Analysis window opens.
2. From the Reports menu choose a report. The report is generated and displayed. You can display
multiple copies of the same report.
The Report Viewer
Each report is displayed in its own report viewer. Each viewer contains a header and a toolbar.
Report Header
The header displays general scenario information. The report header contains the following
information:
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Title: The name of the report.
Scenario: The name of the scenario described in the report.
Result: The pathname of the scenario results directory.
Start time: The time at which the Run Scenario command was executed.
End time: The time at which the scenario script was terminated.
Duration: The total run time of the scenario.
Report Viewer Toolbar
Each report viewer has a toolbar that lets you perform operations on displayed reports. The report
viewer toolbar contains the following buttons:
Zoom: Toggles between an actual size, full page, and magnified views of the report.
Print: Prints the displayed report.

7) Exporting Performance Data
You can export performance data to a spreadsheet application or to a statistical analysis application
for further processing. You can export from the:
# Analysis Window - to generate files with performance information
# Report Viewer - to generate files in a format compatible with a spreadsheet application
Exporting from the Analysis Window
To generate simple text files with performance information, export the data from the Analysis window.
To export performance data from the Analysis window:
1. Click the Analysis button or choose Results > Analyze Results. The Analysis window opens.
2. Click the Export button or choose File > Export. The Export dialog box opens.
3. In the Export Data to Directory box, type the path of the directory to which you want to export the
information. Alternatively, click the browse button next to the box and select a directory with the
Export Path dialog box.
4. From the Data Files list, select the information you want to export. Use the CTRL key to select
multiple files.
5. Click OK to close the dialog box. The data files are exported to the specified directory in text format
with. txt extensions. Each file begins with an explanation of the report and its fields.

Types of Performance Data
You can export the following types of performance data:
Transaction Meter contains information on all the transactions in the scenario, such as the ID of the
Vusers performing the transaction and transaction performance times. The exported file name is
tr_meter.txt .
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Transaction Distribution contains the distribution of the time taken to perform a transaction. The
exported file name is distr.txt .
Running Vusers contains the total number of active Vusers during scenario execution. The exported
file name is vurun.txt .
Transaction Summary contains general information about all transactions in the scenario, such as
the minimum, maximum, and average performance times for all transactions in the scenario. The
exported file name is trans.txt .
General Scenario Information contains the path of the scenario file and the total number of Vusers
in the scenario.The exported file name is sc_map.txt
General Result Information contains the path of the results file and the start and end times for the
scenario. The exported file name is sc_res.txt .
Sgroups contains the name and ID of each Sgroup in the scenario. The exported file name is
sg_res.txt.
Vuser Information contains all the Vusers that were in the RUNNING state during scenario
execution. The exported file name is vu_res.txt .
Vuser Status Contains the status of each Vuser at the end of the scenario ( PASS , FAIL , ABORT ,
ERROR ). The exported file name is vu_stat.txt .
Transactions per Second contains the number of completed transactions during each second of the
scenario. The exported file name is tps.txt.
Performance by Vuser contains transaction performance information for each Vuser in the scenario.
The exported file name is vu_trans.txt.
Performance Under Load contains the performance time for transactions according to the total
number of active Vusers during scenario execution. The exported file name is perf_run.txt.
Data Point contains performance information about user defined points known as data points. The
exported file name is dpoint.txt.
Data Point Map contains a list of the data points measured throughout the scenario. The exported file
name is dp_map.txt
Rendezvous contains information about the rendezvous such as the number of members arrived, the
arrival and release times, and the reason for the release. The exported file name is rendz.txt
Rendezvous Map contains a list of the rendezvous points in the scenario. The exported file name is
rendzmap.txt
Percentile contains the percentage of transactions performed within a given time range. The exported
file name is percent.txt.

Exporting Data from the Report Viewer
From the Report Viewer, you can export analysis data to a file, an Exchange folder, or a Lotus Notes
database for further processing. You can also export LoadRunner reports through Microsoft Mail. The
Report Viewer can export the data into many different file formats such as dBASE, html, and other
popular database or wordprocessor formats. For a list of the available formats, click the arrow to the
right of the Format box to open the drop- down list box.
To export report data to a file:
1. Click the Analysis button or choose Results > Analyze Results. The Analysis window opens.
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2. From the Reports menu choose a report to generate. Wait for the report to open.
3. Click the Export button from the report viewer toolbar. The Export dialog box opens.
4. Click the arrow to the right of the Format box and select a file format from the list.
5. Click the arrow to the right of the Destination box and select a destination from the list.
6. Click OK. The Choose Export File dialog box opens.
7. Specify a name for the export file and click OK. LoadRunner displays the report title in the window
banner and exports the information. A dialog box displays the progress of the export. For example, if
you are exporting the Detailed Vuser report, the dialog box title will read Printing Detailed Vuser.

To export report information using Microsoft Mail
Select Results > Analyze Results to open the LoadRunner Analysis window.
1. From the Reports menu, choose a report to generate. Wait for LoadRunner to display the report.
2. Click the Export button from the report viewer toolbar. The Export dialog box opens.
3. Select Character separated values from the Format box.
4. Select Microsoft Mail from the Destination box
5. Click OK to close the dialog box. The Character-Separated Values dialog box opens.
6. Specify a character to separate between values in the report. The default is a comma. Click OK to
close the dialog box. The Number and Date Format dialog box opens.
7. Check the appropriate boxes and click OK. LoadRunner begins to export the information.

About Scenario Activity
During scenario execution, Vusers generate data as they perform transactions. LoadRunner enables
you to generate graphs that show scenario activity or overall scenario performance. Scenario activity
graphs and reports let you track Vuser behavior throughout the scenario. The graphs map the
transactions, rendezvous, and active status of the Vusers, according to the elapsed scenario time.
When working with graphs, you can focus on specific segments of the scenario using the zoom tools.
In addition, you can change the granularity of the graph.

About Transaction Breakdown
After running a scenario, you perform an analysis of the run by generating graphs and reports. If the
graphs show a reasonable transaction time for the Vusers, you do not need to further analyze the
transactions. However, if the transaction response time is not acceptable, you can use one of
LoadRunner's monitoring tools to pinpoint the problem. The monitoring tools are Transaction
Breakdown, Network Monitoring, and Resource Monitoring.
You use the Transaction Breakdown utility to determine where the bottleneck lies. This utility indicates
the cause of the slow response time: Network or client delays, CPU performance, I/O delays,
database locking, or other issues at the database server. The transaction breakdown utility gives you
detailed information about each of the components by displaying the client/network and server
components for each of the transactions in the scenario.
Once you determine where the problem lies, you can upgrade or reconfigure your system accordingly.
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Understanding Transaction Components
The Transaction Breakdown utility shows the following elements:
# Network and Client: The Network and Client component indicates the effect of the network and
client machine on the transaction response time.
# CPU: The CPU component indicates the effect of database server's CPU time on the transaction
response time.
# I/O: The I/O component indicates the effect of file and disk operations on the transaction response
time.
# Lock: The Lock component indicates the effect of database locking on the transaction response
time.
# Latch: The Latch component indicates the effect of the latch operation in Oracle on the transaction
response time.
# System Locks: The System Locks component indicates the effect of server system locks on the
transaction response time.
# General: The General component shows the effect of all other server elements that do not fit into
one of the above categories on the transaction response time.

Pinpointing Problems
You use the Transaction Breakdown utility to determine which component caused the poor response
time. Prolonged transactions may result from a misconfigured network, a slow CPU, database locking,
I/O (file and disk operations), or other factors.
Without transaction breakdown, you might upgrade the CPU when the real problem lay with database
locking. The transaction breakdown enables you to pinpoint the exact problem, to avoid unnecessary
upgrades and costs.

Database Locking
In the following example, the transaction breakdown indicates that most of the delay to the transaction
time was caused by database locking
In order to improve transaction response time, you should reconfigure the application or modify its
code to prevent database locking. Upgrading the CPU will be of little use, since CPU performance is
not the cause of the problem
To improve transaction response time caused by network delays, use LoadRunner's Network Monitor
to determine the node causing the delay.
To analyze the resource usage on an NT or UNIX machine, use LoadRunner's Resource monitoring.

Improving Response Time
The transaction breakdown graphs show the various components of the transaction time. The network
component always appears on top. The server components are displayed in the order of CPU, I/O,
lock, latch, system locks and general.
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To best utilize the Transaction Breakdown utility, run it several times. First determine the primary
cause of delay. After solving one problem, run the scenario again and use the breakdown utility to
determine the next reason for delay
In the following example, three scenarios were executed with the same settings and the same number
of Vusers.

The Network Traffic
In the second version there was an improvement, but the response time of 10 seconds was still not
acceptable. The bottleneck in version 2 was in the network.
Further investigation determined that 1,000 fetches were performed, resulting in heavy network traffic.
The user modified the application to perform one fetch of 1,000 rows instead of 1,000 fetches of one
row. This lowered the network traffic.
(If the network traffic could not be decreased by modifying the application, use the Network Monitor to
determine the bottleneck.)
In the final version, the transaction response time of 2 seconds was acceptable and the current
configuration was used.
After performing a transaction breakdown for your scenarios, you will have a series of graphs showing
your progress throughout the analysis.

Compare the results from the various scenarios
To compare the results from the various scenarios, use Cross-Scenario analysis to generate a single
graph showing the transaction response time for the various versions. The following graph shows a
Cross-Scenario analysis of the three scenarios.

Enabling Transaction Breakdown
To enable LoadRunner to break down transactions, you must enable transaction breakdown from the
Controller before the scenario run. By default, in order to conserve resources, LoadRunner does not
log the breakdown information.
Note that the Transaction Breakdown feature requires an additional license. If the Transaction
Breakdown option does not appear in the Monitor menu, you must enter a new license code to include
it. You can enter a new license code from the Help > About menu.

To Enabling Transaction Breakdown
Choose Monitors > Transaction Breakdown from the Controller window. The Transaction Breakdown
Monitoring dialog box opens.
1. Select the check box to enable server monitoring for transaction breakdown.
2. Click Add to specify the Oracle server. The Server Information dialog box opens.
3. Enter the name of the Oracle server to monitor and specify a database instance (SID).
4. Select the platform type from the list.
5. Click OK to accept the settings and close the dialog box
6. Repeat steps 3-6 for each Oracle machine whose transactions you want to monitor.
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7. Choose a monitoring policy. Specify the percent of Vusers you want to monitor. To monitor all
Vusers, specify 100%. Choosing a lower percentage of Vusers conserves disk space and reduces
processing time. The default is 10%.
8. Click OK to accept the settings and close the Transaction Breakdown Monitoring dialog box.

To Performing a Transaction Breakdown
The Transaction Breakdown utility is available for three graphs:
# Percentile
# Performance Under Load
# Transaction Performance
To perform a transaction breakdown:
1. Enable Transaction Breakdowns in the Controller.
2. Run the scenario.
3. If Automatic Analysis is not enabled, choose Tools > Analysis to run the analysis.
4. Open one or more of the supported graphs (Percentile, Performance Under Load, or Transaction
Performance).
5. Click the Break Down button or perform a right click and choose Break Down. LoadRunner displays
the components of the transaction.
6. To turn off transaction breakdown, click the Break Down button or perform a right click and choose
Break Down.

8) LoadRunner Features & Benefits
New Tuning Module Add-In
The LoadRunner Tuning Module allows customers to isolate and resolve system performance
bottlenecks. Once the application has been stress tested using LoadRunner, the Tuning Module
provides component test libraries and a knowledgebase that help users isolate and resolve
performance bottlenecks.

WAN Emulation Support
This powerful feature set enables LoadRunner to quickly point out the effect of the wide area network
(WAN) on application reliability, performance, and response time. Provided through technology from
Shunra Software, this WAN emulation capability introduces testing for bandwidth limits, latency,
network errors, and more to LoadRunner.

Sun ONE Studio4 IDE Add-in
Mercury Interactive and Sun Microsystems have worked together to integrate LoadRunner with the
Sun ONE Studio4 add-in.
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JBuilder for Java IDE Add-in
LoadRunner now works with Borland's JBuilder integrated development environment (IDE) to create
powerful support for J2EE applications. This add-in enables LoadRunner users who create J2EE
applications and services with JBuilder to create virtual users based on source code within a JBuilder
project.

Native ICA Support for Citrix MetaFrame
LoadRunner now supports Citrix's Independent Computing Architecture (ICA) for the testing of
applications being deployed with Citrix MetaFrame. This support is the first native ICA load testing
solution of its kind, jointly developed with Citrix.

Web Transaction Breakdown Monitor for Isolating Performance Problems
Now you can more efficiently isolate performance problems within your architecture. LoadRunner's
Web Transaction Breakdown Monitor splits end-to-end transaction response times for the client,
network, and server and provides powerful drill-down capabilities.

Data Wizard for Data-Driven Testing
LoadRunner's Data Wizard enables you to quickly create data-driven tests and eliminate manual data
manipulation. It connects directly to back-end database servers and imports desired data into test
scripts.

Goal-Oriented Testing with AutoLoad
The new AutoLoad technology allows you to pre-define your testing objectives beyond the number of
concurrent users to streamline the testing process.

Enterprise Java Bean Testing
By testing EJB components with LoadRunner, you can identify and solve problems during the early
stages of application development. As a result, you can optimize performance before clients have
been developed and thereby save time and resources.

XML Support
With LoadRunner's XML support, you can quickly and easily view and manipulate XML data within the
test scripts

9) Hosted Virtual Users
How it Work
LoadRunner Hosted Virtual Users complements in-house load testing tools and allows companies to
load test their Web-based applications from outside the firewall using Mercury Interactive's
infrastructure. Customers begin by using LoadRunner Hosted Virtual Users' simple Web interface to
schedule tests and reserve machines on Mercury Interactive's load farm. At the scheduled time, they
select the recorded scripts to be uploaded and start running the tests on the host machines*. These
scripts will emulate the behavior of real users on the application and generate load on the system.
www.softwaretestinggenius.com
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Through LoadRunner Hosted Virtual Users Web interface, testers can view real-time performance
metrics, such as hits per second, throughput, transaction response times and hardware resource
usage (e.g., CPU and memory levels). They also can view performance metrics gathered by Mercury
Interactive s server monitors and correlate this with end-user performance data to diagnose
bottlenecks on the back end.
The interface to LoadRunner Hosted Virtual Users enables test teams to control the load test and
view tests in progress, no matter their locations. When the test is complete, testers can analyze
results online, as well as download data for further analysis.
*Customers who do not own LoadRunner can download the VUGen component for free to record their
scripts. Likewise, the LoadRunner analysis pack can be downloaded for free.
LoadRunner Hosted Virtual Users gives testers complete control of the testing process while providing
critical real-time performance information, as well as views of the individual machines generating the
load.

Features and Benefits
Provides pre- and post-deployment testing.
At any time in the application lifecycle, organizations can use LoadRunner HostedM Virtual Users to
verify performance and fine-tune systems for greater efficiency, scalability and availability. The
application under test only needs to be accessible via the Web.
Complements in-house solutions to provide comprehensive load testing.
By combining LoadRunner Hosted Virtual Users with Mercury Interactive's LoadRunner or another inhouse load testing tool, operations groups can thoroughly load test their Web applications and
Internet infrastructures from inside and outside the firewall.
Gives customers complete control over all load testing.
Testing groups create the scripts, run the tests and perform their own analyses. They can perform
testing at their convenience and easily access all performance data to quickly diagnose performance
problems.
Provides access to Mercury Interactive's extensive load testing infrastructure.
With LoadRunner Hosted Virtual Users, organizations do not need to invest inadditional hardware,
software or bandwidth to increase their testing coverage. Mercury Interactive s load testing
infrastructure is available 24x7 and consists of load farms located worldwide. As a result,
organizations can generate real-user loads over the Internet to stress their Web-based applications at
any time, from anywhere.

10) How the Monitors Work
To minimize the impact of the monitoring on the system under test, LoadRunner enables IT groups to
extract data without having to install intrusive capture agents on the monitored servers. As a result,
LoadRunner can be used to monitor the performance of the servers regardless of the hardware and
operating system on which they run. Setup and installation of the monitors therefore is trivial. Since all
the monitoring information is sampled at a low frequency (typically 1 to 5 seconds) there is only a
negligible effect on the servers.
Supported Monitors
Astra LoadTest and LoadRunner support monitors for the following components:
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Client-side Monitors
End-to-end transaction monitors - Provide end-user response times, hits per second, transactions per
second
Hits per Second and Throughput
Hits per Second
The Hits per Second graph shows the number of hits on the Web server (y-axis) as a function of the
elapsed time in the scenario (x-axis). This graph can display the whole scenario, or the last 60, 180,
600 or 3600 seconds. You can compare this graph to the Transaction Response Time graph to see
how the number of hits affects transaction performance.
Throughput
The Throughput graph shows the amount of throughput on the Web server (y-axis) during each
second of the scenario run (x-axis). Throughput is measured in kilobytes and represents the amount
of data that the Vusers received from the server at any given second. You can compare this graph to
the Transaction Response Time graph to see how the throughput affects transaction performance.
HTTP Responses
The HTTP Responses per Second graph shows the number of HTTP status codes, which indicate the
status of HTTP requests, for example, the request was successful,the page was not found returned
from the Web server during each second of the scenario run (x-axis), grouped by status code.
Load Testing Monitors
Pages Downloaded per Second
# Pages Downloaded per Second The Pages Downloaded per Second graph shows the number of
Web pages downloaded from the server during each second of the scenario run. This graph helps you
evaluate the amount of load Vusers generate, in terms of the number of pages downloaded. Like
throughput, downloaded pages per second is a representation of the amount of data that the Vusers
received from the server at any given second.
User-defined Data Point
User Defined Data Points graph allows you to add your own measurements by defining a data point
function in your Vuser script. Data point information is gathered each time the script executes the
function or step. The User-Defined Data Point graph shows the average value of the data points
during the scenario run. The x-axis represents the number of seconds elapsed since the start time of
the run. The y-axis displays the average values of the recorded data point statements.

Transaction Monitors
# Transaction Response Time The Transaction Response time graph shows the response time of
transactions in seconds (y-axis) as a function of the elapsed time in the scenario (x-axis).
# Transaction per Second (Passed) The Transaction per Second (Passed) graph shows the number
of successful transactions performed per second (yaxis) as a function of the elapsed time in the
scenario (x-axis).
# Transaction per Second (Failed) The Transaction per Second (Failed) graph shows the number of
failed transactions per second (y- axis) as a function of the elapsed time in the scenario (x- axis).
Virtual User Status

www.softwaretestinggenius.com

Page 31 of 32

An Introduction to LoadRunner – A Powerful Performance Testing Tool by HP
The monitor's Runtime graph provides information about the status of the Vusers running in the
current scenario on all host machines. The graph shows the number of running Vusers, while the
information in the legend indicates the number of Vusers in each state.
The Status field of each Vuser displays the current status of the Vuser. The following table describes
each Vuser status.
# Running The total number of Vusers currently running on all load generators.
# Ready The number of Vusers that completed the initialization section of the script and are ready to
run.
# Finished The number of Vusers that have finished running. This includes both Vusers that passed
and failed
# Error The number of Vusers whose execution generated an error.
Web Transaction Breakdown Graphs
# DNS Resolution Displays the amount of time needed to resolve the DNS name to an IP address,
using the closest DNS server. The DNS Lookup measurement is a good indicator of problems in DNS
resolution, or problems with the DNS server.
# Connection Time Displays the amount of time needed to establish an initial connection with the
Web server hosting the specified URL. The connection measurement is a good indicator of problems
along the network. It also indicates whether the server is responsive to requests.
# Time To First Buffer Displays the amount of time that passes from the initial HTTP request (usually
GET) until the first buffer is successfully received back from the Web server. The first buffer
measurement is a good indicator of Web server delay as well as network latency.
# Server and Network time The Time to First Buffer Breakdown graph also displays each Web page
component's relative server and network time (in seconds) for the period of time until the first buffer is
successfully received back from the Web server. If the download time for a component is high, you
can use this graph to determine whether the problem is server- or network related.
# Receive Time Displays the amount of time that passes until the last byte arrives from the server
and the downloading is complete. The Receivemeasurement is a good indicator of network quality
(look at the time/size ratio to calculate receive rate).
# Client Time Displays the average amount of time that passes while a request is delayed on the
client machine due to browser think time or other clientrelated delays.
# Error Time Displays the average amount of time that passes from the moment an HTTP request is
sent until the moment an error message (HTTP errors only) is returned
# SSL Handshaking Time Displays the amount of time taken to establish an SSL connection
(includes the client hello, server hello, client public key transfer, server certificate transfer, and other
stages). The SSL Handshaking measurement is only applicable for HTTPS communications
# FTP Authentication Displays the time taken to authenticate the client. With FTP, a server must
authenticate a client before it starts processing the client's commands. The FTP Authentication
measurement is only applicable for FTP protocol communications.
Server Monitors
NT /UNIX / Linux monitors - Provide hardware, network and operating system performance metrics,
such as CPU, memory and network throughput.
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